Medium Format Family

Register a free account now!

If you are registered, you get access to the members only section, can participate in the buy & sell second hand forum and last but not least you can reserve your preferred username before someone else takes it.

500 elm mirror newbie clueless

cunningham

New Member
Just purchased a 500 el/m minus lense (didn't pay a great shake). The mirror is locked in the up position, battery working, shaft is pointing to the red dot next to it. Is this normal as I don't have a lense attached or have I a nice looking turkey?
Any ideas appreciated.
Cheers
 

qnu

Banned
Peter,

Does it stay up there, no matter what?
Or does it end up there after doing other things?

If the latter, try setting the large dial to "O", and press the release once more.

If the first, it indeed looks like it is turkey.
 

ttam

New Member
>Hello Peter,

Make sure your function dial IS NOT SET TO 'AS,' if it is, try setting it to 'O' and try operating the camera again.

Hope it works,

Tsun >
 

cunningham

New Member
Hi
I've tried every combination of settings include your suggested ones and all I hear is a click/clunk sound and the mirror stays up.
 

qnu

Banned
Then the only thing to do is contact the seller, and either let him/her pay for fixing it, or return the camera and get your money back.
Sorry!
 

cunningham

New Member
Hi Gérard,
sadly no. it's just as stuck as it was before, none of the above worked. It's a really nice ornament though. I am now looking on ebay for a decent priced 500c/m kit to get me started. Just waiting for the right one.
Cheers
Peter
Gerard Morris (Austin) wrote on September 12:

' 2007 - 11:59 am,'
 

cristif

Member
Hello Peter,
In case you still have that broken 500 EL/M body and plan to trade it for something, please let me know, I am looking exactly for this.
Cheers,

Cristian
 
Top