A12 "eating" film

edhannon

New Member
I just purchased a 500C with A12, prism finder, and 80mm lens from Keh. All work great except the A12. It is very difficult to load the film holder into the A12. I have to remove the black out slide and push down the film to get the holder into the A12 - also to get it out again. Now the holder is turning very hard and in fact tore the film paper with my last load.

Am I loading it wrong or is the A12 damaged? How can I tell?
 

polypal

New Member
Problems fitting the film holder in the housing can have a number of different causes.
Now that the back is as good as seized it is save to say this back needs attention.
This back was recently purchased from KEH so send it back and ask for a good working replacement.
The problems described make me believe youre filmback was dropped and will not align.
The filmplane will be off meaning all pictures are out of focus.

I assume you have loaded the film correctly and guided the film and the paper under the metal
guide that is on the far end looking from the lever to lock the holder in the housing.
In case you do not have a manual these can be downloaded from Hasselblad.se
You will need to register as a user with details of the product you use.
The 500C is not listed just report you have a 501C and fill in the number of the body.
 

edhannon

New Member
Thanks for the help. I was able to find a manual on line and verified that I am loading correctly.

I will contact KEH.
 

edhannon

New Member
Contacted KEH. They said to send the back in for repair/replacement/refund.

Ordered a replacement back and will send in the old back when it gets here tomorrow!
 

polypal

New Member
With the back you will receive tomorrow make sure when you load the film
that the film is stuck under the tab at the far end from the insert seen from
where the control is to lock the insert in the housing.
If this is not observed moving the film will become more difficult.
The film also loses the correct position resulting in out of focus images.
 

edhannon

New Member
I was out of town Thursday. So did not get the new (used) back until yesterday. It works so much smoother! Did a calibration roll of Ilford B&W bracketed around Zone I). It is raining today on the Florida Sunshine Coast! But if it is nice Monday, I will try some Fuji film color of flowers in my sister-in-laws garden.
 
Top