Medium Format Family

Register a free account now!

If you are registered, you get access to the members only section, can participate in the buy & sell second hand forum and last but not least you can reserve your preferred username before someone else takes it.

H1 quirks anyone

pascal

New Member
Hello, I am using a Hasselblad H1 since a good month, together with the HC 80/2.8 and the zoom HC 50-110. This is a fine combination, but I wanted to check whether some of the quirks I am experiencing are shared by other H1 users.
Once I had the mentioning "lens error" and no shot could be taken. When I switched the camera back off/on, it worked and never happened again.
Last weekend, several times the error message "no lens" was displayed on the LCD screen although the lens was on and had worked before. On/off did not help. It took taking off the lens and putting back on before the camera would work again.
Note that these issues happened with different lenses, not always the same lens.
Are these quirks "normal"? The camera body has +9000 actuations.
Reactions welcome :)
 

pascal

New Member
Hi Nick,
would the update towards the H2 do the trick, or is there another (cheaper) H1 firmware upgrade?
 

mark1958

New Member
>[I have an H2 and a leaf aptus 65 back. I do on occassion get some >sort of error or lockup requiring a reboot of the back. I would say >once every 500 -1000 shots on average.]
 

nickt

New Member
>

An update to an H2 will get you the latest firmware plus the much better 7.2V rechargeable battery, other advantages of the H2 only come into play when using a hasselblad back on the camera. From memory the price of the upgrade wasn't much different to the price of a rechargeable hand grip and charger so it's a good deal.
 

pascal

New Member
yes that rechargeable battery would be an advantage for a full-time user, but somehow I don't think it would in my case. Also, I am shooting film, not digital so no advantage there either. Are there firmware upgrades available for the H1, without having to move to the H2? What is the latest firmware number available for the H1?
 

pascal

New Member
Hi to all. As an update to this thread I wanted to inform that the H1 got the latest firmware installed (9.3.2). It indeed appeared that the firmware was a very early version (7.0.0). This took about 30 minutes work and was charged 58 euro. No other fixes were needed, the camera is in perfect working order. An update to the H2 (basically the rechargeable battery) was not recommended by the importer, unless one wanted to add a digital back.
 

pascal

New Member
Another update: after rewinding a film automatically, the LCD panel on the hand grip gave the following display "Reattach Magazine". Taking out the film insert and putting it back did not solve it. I had to take off the entire film magazine and put it back on before the error message disappeared. Would anyone know if this is normal? Thanks.
Pascal
 

fotografz

Active Member
Lost connection between the body and back. Removing the insert would not correct that.

Be sure the contact points are clean. Do NOT use an eraser or any abrasive to clean them. Just polish them with a soft cloth and blow it all off.
 
Pascal,

I recently upgraded my two film H2s, but the problem you describe with the film back and the error message occurred frequently with both of my bodies.

I was in touch with Hassellbad about it (2005/2006, send the bodies in a couple of times), they did try to fix it and with firmware updates they reduced the frequency of the error (perhaps once every 10 roll changes); but there were times, in high-winds, rain, while standing in a river, in snow, where ever, it would tell me to pop off the magazine and reattach. Get used to it and practice so you will do it rapidly when in the elements. It has nothing to do with the contacts. Good luck!

Kind regards,
Derek
 

pascal

New Member
Hi Derek,

thanks for the confirmation that I am not alone in this. Luckily, the issue has not reproduced itself anymore (touch wood). I also got a reply from a Hasselblad technician according to which a new E-prom co-processor with brake should be installed to take care of the issue. Apparently, this was an issue with earlier H1 models and would have been changed on later models of the H1 camera. But since you say you also had it with H2 bodies, I doubt it whether the solution Hasselblad has suggested, would really do it.
Pascal
 

erick

New Member
my batteries for H1 are getting old, do you think it is possible to find new batteries for H1 ? or is it better to upgrade to H2 and get new system batteries ?
 
Top